Maintainer:
ole_yansen
Rating:
3.666665
Average: 3.7 (9 votes)
Application:
Writer
Tags:
free, , writer, , language tools,
Screenshots:
https://sourceforge.net/project/screenshots.php?group_id=207409
Source code:
http://anaphraseus.svn.sourceforge.net/viewvc/anaphraseus/
Post date:
Tuesday, 10 June, 2008 - 07:45
Statistics
Week: 23 - Month: 104 - Year: 1,248 - Timeline
Download extension
System Independent version - All releases
Compatible with OpenOffice 4: Yes
User feedback:
Compatible with OpenOffice 4.x?

Anaphraseus is a CAT (Computer Aided Translation) tool, an OpenOffice.org 2 macro set similar to the famous Wordfast. It works with the Wordfast Translation Memory format (*.TXT), and supports text segmentation.
Features:

  • Term Recognition.
  • Fuzzy Search.
  • Unicode UTF-16 TMX Export/Import
  • Plain text and Unicode UTF-16 TM, Glossary
  • User Glossary
  • German, Russian, Italian, Latvian localizations available at Sourceforge.net
Anaphraseus

Version Operating system Compatibility Release date
2.05.126b System Independent 2.x, 3.0, 3.1, 3.2, 3.3, 3.4, 4.0 16/04/2014 - 06:27 More information Download
2.01.131b System Independent 2.x, 3.0, 3.1, 3.2, 3.3, 3.4 19/03/2010 - 09:26 More information Download
System Independent -- 06/07/2009 - 15:40 More information Download
1.23-beta System Independent 2.x, 3.0, 3.1, 3.2, 3.3, 3.4 02/07/2009 - 11:20 More information Download
1.21-beta System Independent 2.x, 3.0, 3.1, 3.2, 3.3, 3.4 10/06/2008 - 07:54 More information Download

Comments

I tried to install it on OOo 3.3.0 and LibreOffice 3.3.2 and in both cases got an error message (bad root element etc) so I couldn't get it to work.

Hello!

I tried this extension but got an error messages when closing stating that some scripts couldn't be found:
library "Standard"
module "Anaphraseus"
method "BeforeClose"
location "application"

The extension manager failed to remove the extension neither the uninstall menu alternative worked (tried in that order). I then used SpotLight to locate every file with word "Anaphraseus" and either removed then or edited them (in case of menubar.xml; yes, I did only removed those lines relevant to Anaphraseus).

Anyway, now I have an OpenOffice installation where closing every text document generates the error above even if there is no more Anaphraseus menu.

How do I get rid off it or do I have to reinstall OpenOffice from scratch?

Mac OS X 10.4.11 (PPC)
OpenOffice 3.2.0 build 9483

TIA,

Metsis

Sorry for delay with answer, usually we pay attention to bug-report on Anaphraseus site (http://sourceforge.net/projects/anaphraseus/).
To correct uninstalling this addon one should use "Uninstall Anaphraseus" menu item from Anaphraseus' menu.
This feature also available through Installation Guide (http://sourceforge.net/projects/anaphraseus/files/Anaphraseus%20OOo%20Extension/Installation%20Guide/Readme_Eng.odt/download) - it contain macros for handling this problem.

Best regards, Ole.

Anaphraseus 1.22b loaded my previous Wordfast TM fine, then I translated the first segment in my document and hit the "Translate" icon to move to the next segment. Now I got a new error: "OpenBasic Error in HideTranslation: 'Index out of defined range.' Line 53". No macro was opened. When I hit "OK", the next segment opens, and it seems I can translate it normally. Then I hit the "End Translation" icon and the "Clean-Up" icon. Then I opened my TM in a text editor but couldn't find the TU I just translated. Please help. I am using OpenOffice.org 3.0 and Windows XP Pro SP3. Thanks.

I have been using Wordfast for years, so I would like to start using Anaphraseus, however after installing the extension and loading my existing Wordfast TM, I get the following error message: "Inadmissible value or data type. Index out of defined range." The macro LibAnaphrase/TMLoad is opened and the following statement in function GetTabVal() is selected: "GetTabVal = a(I)". 3150 of the 7249 TUs in the TM were loaded. The TM still works fine in Word with Wordfast. Please help. Thanks.

Since encountering the above error in Anaphraseus 1.21 (the latest version available at extensions.services.openoffice.org), I have installed version 1.22b (beta) available from sourceforge.net. The error seems to have been fixed. Now I will test the extension.